Impression 3D

D’une révolution nous passons aux évolutions, l’imprimante 3D est en passe de transformer notre quotidien en se démocratisant avec des modèles de plus en plus performants et simples d’usage.

L’impression 3D est une formidable aventure que nous vous proposons de partager au travers de ce forum.
Forum spécialisé BQ Witbox, Hephestos , Witbox 2, Hephestos 2, Witbox Go!

Mesure des températures avec courbes

Posez ici vos questions techniques avec ou sans rapport à l'impression 3D

Retour vers Sujets de technique générale

par Tim0th3e » Ven Jan 22, 2016 4:36 pm

Je comprend la chose. J'ai déjà essayé avec un pwm de 255, soit 100% du courant:
Code : Tout sélectionner
if (temp < 24) {
    Serial.println("TEMPERATURE INFERIEURE A 24 DEGRES, VENTILATEUR A L'ARRET");
    analogWrite(pin_ventilo, 0);
    delay(100);
  }
    else if (temp > 32) {
    Serial.println("TEMPERATURE SUPPERIEURE A 32 DEGRES, VENTILATEUR A 100%");
    analogWrite(pin_ventilo, 255);
    delay(100);
    }

Quand je démarre le programme, pas de problèmes. Mais quand je chauffe le capteur à plus de 32°, rien ne change, le ventilateur ne bouge pas.
J'ai aussi tout simplement essayé de mettre une tension normale à la borne de contrôle du mosfet:
Code : Tout sélectionner
int fan = 9;
void setup() {
  pinMode(fan, OUTPUT);
}

void loop() {
  digitalWrite(fan, HIGH);
}

Mais même avec cela le ventilateur ne bouge pas.
Je commence à me demander si ce ventilateur ne serait pas apte à recevoir autre que du 12v... :?
«Le monde appartient aux optimistes, les pessimistes ne sont que des spectateurs» – François Guizot
Avatar de l’utilisateur
Tim0th3e
Contributeur actif
 
Message(s) : 215
Inscrit le : Sam Oct 25, 2014 9:02 am
Localisation : Suisse et 16 ans :)
Imprimante 3D: Prusa i3 Hephestos bleue avec plateau chauffant

par Jacques » Ven Jan 22, 2016 8:18 pm

Refait ton schéma car nous parlons dans le vide.
Le ventilateur est bien commandé en 12V selon le premier schéma. En 5V il risque de ne pas tourner.
Ensuite comme dit plus haut, la résistance de 4,7 K est bien trop importante, 50 ohms ou rien du tout devrait fonctionner.

Regarde ce schéma, le out du CI part directement au mosfet, le moteur est connecté au 12V passe par le mos qui est relié à la masse.
A la place du moteur tu peux mettre une led avec sa résistance, une petite ampoule 12V de voiture par exemple.
Quand ca ne marche pas il faut simplifier. Tu as simplifié le programme, il faut maintenant simplifier le schéma afin de comprendre ce qui ne va pas.

Image
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Premium, la qualité, le service en plus.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 3601
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par Tim0th3e » Ven Jan 22, 2016 10:27 pm

Jacques a écrit:Refait ton schéma car nous parlons dans le vide.
Le ventilateur est bien commandé en 12V selon le premier schéma. En 5V il risque de ne pas tourner.
Ensuite comme dit plus haut, la résistance de 4,7 K est bien trop importante, 50 ohms ou rien du tout devrait fonctionner.

J'ai refait le schéma et j'ai enlevé la résistance:

20160122122143.jpg


J'ai simplifié le montage avec une simple led et sa résistance. Par contre je l'ai fait sans le transistor de puissance.
«Le monde appartient aux optimistes, les pessimistes ne sont que des spectateurs» – François Guizot
Avatar de l’utilisateur
Tim0th3e
Contributeur actif
 
Message(s) : 215
Inscrit le : Sam Oct 25, 2014 9:02 am
Localisation : Suisse et 16 ans :)
Imprimante 3D: Prusa i3 Hephestos bleue avec plateau chauffant

par Jacques » Sam Jan 23, 2016 12:37 am

Bon, tu peux laisser la led sur la patte arduino et mettre le transistor ainsi que le ventilateur (comme dans mon schéma).
Le led indiquera le bon fonctionnement arduino. On peut aussi mettre une led avec une résistance de 1K à la place du ventilateur, ca permet de contrôler le fonctionnement du transistor.
Ensuite, si ca fonctionne, on peut essayer une lampe de voiture par exemple.
Si ca ne fonctionne pas, il faudrait peut être s'assurer du brochage du transistor ou le changer au cas ou
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Premium, la qualité, le service en plus.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 3601
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par Tim0th3e » Sam Jan 23, 2016 6:33 pm

J'ai essayé avec une led 12v (celles que j'ai dans ma boîte). J'ai tout simplement exécuté le programme de base juste en disant à l'arduino:
Code : Tout sélectionner
int fan = 9;
void setup() {
  pinMode(fan, OUTPUT);
}

void loop() {
  digitalWrite(fan, HIGH);
}


Quand je le lance, rien. Mais quand je pince le collecteur du mosfet, il y a une très très faible lumière sur la led...

IMG_0800.JPG
Quand je pince le collecteur
IMG_0800.JPG (66.06 Kio) Consulté 1875 fois


IMG_0799.JPG
Quand on ne touche à rien
IMG_0799.JPG (72.58 Kio) Consulté 1875 fois
«Le monde appartient aux optimistes, les pessimistes ne sont que des spectateurs» – François Guizot
Avatar de l’utilisateur
Tim0th3e
Contributeur actif
 
Message(s) : 215
Inscrit le : Sam Oct 25, 2014 9:02 am
Localisation : Suisse et 16 ans :)
Imprimante 3D: Prusa i3 Hephestos bleue avec plateau chauffant

par Tiflo » Sam Jan 23, 2016 6:47 pm

Datasheet du mosfet ?
ça veut dire quoi "pincer le collecteur" (on ne parle pas de collecteur pour un mosfet) ?
Il y a bien 5V sur entre la grille et la source du mosfet quand il est activé ?
Quel est l'alim 12V utilisée et de quelle puissance ?
Photo du montage ?

Avec les infos que l'on a, il n'y a aucune raison que cela ne fonctionne pas.

En passant, pour l'utilisation d'un ventilateur, prévoir une diode de roue libre en parallèle de ce dernier.
Tiflo
Contributeur
 
Message(s) : 76
Inscrit le : Dim Déc 27, 2015 1:36 am
Imprimante 3D: Prusa i3 Hephestos BQ

par Tim0th3e » Sam Jan 23, 2016 6:59 pm

Merci pour ta réponse Tiflo

Tiflo a écrit:Datasheet du mosfet ?

Juste ici ;)

Tiflo a écrit:ça veut dire quoi "pincer le collecteur" (on ne parle pas de collecteur pour un mosfet) ?

Je crois que j'au utilisé le mauvais terme, il s'agit de la partie supérieure du mosfet avec un trou

Tiflo a écrit:Quel est l'alim 12V utilisée et de quelle puissance ?

Alim 12v (celle qui est vendue avec la prusa de base) soit 12v, 8A

Tiflo a écrit:Photo du montage ?

IMG_0803.JPG
IMG_0803.JPG (120.98 Kio) Consulté 1870 fois

IMG_0802.JPG
IMG_0802.JPG (106.88 Kio) Consulté 1870 fois

IMG_0801.JPG
IMG_0801.JPG (138.36 Kio) Consulté 1870 fois


Tiflo a écrit:Avec les infos que l'ont a, il n'y a aucune raison que cela ne fonctionne pas.

C'est ce que je me dis aussi, j'ai vérifié plusieurs fois le programme, mais le problème ne vient pas de la, vu que ça fonctionne avec une simple led et une résistance.

Tiflo a écrit:En passant, pour l'utilisation d'un ventilateur, prévoir une diode de roue libre en parallèle de ce dernier.

Est-ce possible de faire sans car je n'en ai pas?
«Le monde appartient aux optimistes, les pessimistes ne sont que des spectateurs» – François Guizot
Avatar de l’utilisateur
Tim0th3e
Contributeur actif
 
Message(s) : 215
Inscrit le : Sam Oct 25, 2014 9:02 am
Localisation : Suisse et 16 ans :)
Imprimante 3D: Prusa i3 Hephestos bleue avec plateau chauffant

par Tiflo » Sam Jan 23, 2016 7:21 pm

Est-ce possible de faire sans car je n'en ai pas?

Je ne sais pas si cette diode est incluse dans le ventilateur (j'en doute), mais si elle est absente tu risques de détruire ton mosfet en arrêtant ton système.

La partie avec le trou est connectée au drain, ça ne doit pas changer grand chose si tu y touches (peut-être un faux contact dans ta plaquette d'expérimentation).

C'est ce que je me dis aussi, j'ai vérifié plusieurs fois le programme, mais le problème ne vient pas de la, vu que ça fonctionne avec une simple led et une résistance.

Une simple led ne consomme rien du tout, ça ne veut pas dire que ton mosfet s'ouvre complètement.


Pour tester ton mosfet, branche directement la GATE sur le pin 5V de ton arduino.

On ne le voit pas sur tes photos, mais vérifie que la masse de l'arduino et de ton alimentation 12V est commune également (attention a ne pas faire n'importe quoi, 12V / 8A ça fait beaucoup de puissance pour bricoler)
Tiflo
Contributeur
 
Message(s) : 76
Inscrit le : Dim Déc 27, 2015 1:36 am
Imprimante 3D: Prusa i3 Hephestos BQ

par Tim0th3e » Sam Jan 23, 2016 7:46 pm

J'ai branché le gate sur le 5v mais rien ne se passe.
Tiflo a écrit:On ne le voit pas sur tes photos, mais vérifie que la masse de l'arduino et de ton alimentation 12V est commune également

Dans mon montage, la masse du ventilo (12v) est connectée au drain et la masse de l'arduino (GND) sur la source.
«Le monde appartient aux optimistes, les pessimistes ne sont que des spectateurs» – François Guizot
Avatar de l’utilisateur
Tim0th3e
Contributeur actif
 
Message(s) : 215
Inscrit le : Sam Oct 25, 2014 9:02 am
Localisation : Suisse et 16 ans :)
Imprimante 3D: Prusa i3 Hephestos bleue avec plateau chauffant

par Tiflo » Sam Jan 23, 2016 8:17 pm

et la masse de l'alim 12V ?
Dernière édition par Tiflo le Sam Jan 23, 2016 8:26 pm, édité 2 fois.
Tiflo
Contributeur
 
Message(s) : 76
Inscrit le : Dim Déc 27, 2015 1:36 am
Imprimante 3D: Prusa i3 Hephestos BQ

par Tim0th3e » Sam Jan 23, 2016 8:25 pm

Elle n'est ralliée à rien... :!:
«Le monde appartient aux optimistes, les pessimistes ne sont que des spectateurs» – François Guizot
Avatar de l’utilisateur
Tim0th3e
Contributeur actif
 
Message(s) : 215
Inscrit le : Sam Oct 25, 2014 9:02 am
Localisation : Suisse et 16 ans :)
Imprimante 3D: Prusa i3 Hephestos bleue avec plateau chauffant

par Tiflo » Sam Jan 23, 2016 8:27 pm

Ok ... il faut impérativement que la masse de l'alim 12V soit connectée aussi sur le GND de l'arduino.
Si ce n'est pas fait, ton alim ne débitera aucun courant et rien ne s’allumera.
Tiflo
Contributeur
 
Message(s) : 76
Inscrit le : Dim Déc 27, 2015 1:36 am
Imprimante 3D: Prusa i3 Hephestos BQ

par Tim0th3e » Sam Jan 23, 2016 9:30 pm

J'ai relié la masse du ventilateur et ça fonctionne ^:)^. C'était en fait quelque chose de tout con comme on dit :D. Merci beaucoup pour votre aide Tiflo et Jacques.

Par contre avec un pwm à 0 le ventilateur continue de tourner très lentement. Avec un pwm de 20% et 40%, le ventilateur émet un petit grésillement, un condensateur pourrai-t-il améliorer la chose? (j'en ai un de 10v 22uF)
«Le monde appartient aux optimistes, les pessimistes ne sont que des spectateurs» – François Guizot
Avatar de l’utilisateur
Tim0th3e
Contributeur actif
 
Message(s) : 215
Inscrit le : Sam Oct 25, 2014 9:02 am
Localisation : Suisse et 16 ans :)
Imprimante 3D: Prusa i3 Hephestos bleue avec plateau chauffant

par Jacques » Sam Jan 23, 2016 9:42 pm

D'où l(utilité de faire un schéma complet.
Une tension est toujours relative à quelque chose, le 5v par rapport à sa masse, le 12V n'est rien par rapport au 5V, c'est la masse commune qui lui donne un référence par rapport au 5V.
Non, on ne met pas de condensateur sur un PWM.Il faudrait débrancher le signal du transistor pour voir si le ventilateur tourne toujours. Si oui, il faudrait changer le transistor tout en mettant une diode dans le sens non passant à ses bornes.
Le grésillement est certainement lié au ventilateur lui-même qui doit avoir une électronique.
Vous cherchez une imprimante, du filament, une pièce détachée, visitez notre boutique, https://boutique.premium-computer.fr/
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Premium, la qualité, le service en plus.
Avatar de l’utilisateur
Jacques
Site Admin
 
Message(s) : 3601
Inscrit le : Jeu Oct 23, 2014 3:02 pm
Localisation : Gonesse (95)
Imprimante 3D: Witbox et Hephestos

par Tim0th3e » Sam Jan 23, 2016 9:53 pm

Quand je débranche le signal (source) du mosfet, le ventilateur s'arrête de tourner. Par contre au moindre retranchement il se remet à tourner.
«Le monde appartient aux optimistes, les pessimistes ne sont que des spectateurs» – François Guizot
Avatar de l’utilisateur
Tim0th3e
Contributeur actif
 
Message(s) : 215
Inscrit le : Sam Oct 25, 2014 9:02 am
Localisation : Suisse et 16 ans :)
Imprimante 3D: Prusa i3 Hephestos bleue avec plateau chauffant

PrécédentSuivant

Retour vers Sujets de technique générale