problème CR10S (non pro, la version de 2018)

Exposez ici vos problème techniques matériels
Répondre
titie3325
Nouveau membre
Messages : 7
Inscription : mar. nov. 29, 2022 9:19 pm
Imprimante 3D : CR10S de 2018

Bonjour,

j'ai un soucis avec ma CR10S depuis quelques temps.

en effet, durant l'impression ou meme avant, elle modifie d'elle meme les paramètres. Que ce soit la vitesse, les températures ou meme la vitesse du ventilo...

elle arrive meme a avorter des prints qui fonctionnent juste avant.

elle est full stock de 2018. Les seules modifications que j'ai faites sont l'extrudeur alu et le capricorne.

je l'ai mise dans un caisson au printemps qui est ouvert avec une aération pour le boitier. Le boitier est sur élevé également pour faciliter la circulation de l'air. j'ai des soucis depuis novembre avec.

ce sont toujours les ventilos d'origine... j'ai cette imprimante depuis 2018 et elle a bien tourné ... je vais changer les ventilos de la tete d'impression dès que j'aurais les ventilos.

cependant, j'aimerai comprendre pourquoi d'un coup elle déconne comme ca? je n'ai rien changé...

y a t il du monde qui a rencontré le meme problème? la carte mère a t elle pris un coup de chaud? où puis je en trouver une autre? la carte SD ?

je pense sortir le boitier du caisson! voire refaire mon caisson.

Merci de votre aide!

Titie3325
Pièces jointes
IMG_2674.jpeg
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Dans la mesure ou tous les paramètres peuvent êtres modifiés par le G-code, il faut absolument écarter ce problème en utilisant un g-code dont on est certain qu'il ne pose pas de problème (ancien g-code par exemple)
IL est donc important de bien fixer les problèmes avant de continuer.
Si des valeurs changent alors que l'imprimante ne fait rien, c'est un indicateur très important à confirmer.
Un ventilateur qui tourne moins vite sans raison est le signe éventuel d'un problème d'alimentation. Vérifiez votre 12V s'il est bien stable et aussi le 5V qui pourrait provoquer des défauts sur le fonctionnement du processeur.
Le 12v peut perdre au maximum 0,5V au niveau de l'alimentation lorsque la chauffe se met en marche.
Le 5V ne doit pas varier de plus de 0,1v dans tous les cas
Sans défaut manifeste d'alimentation, vérifiez tous les branchements entre l'alimentation et votre carte mère (en particulier les vis de l'alimentation).
Procédez par élimination, logique et confirmez bien les symptômes avec l'état dans lequel est votre imprimante.
Ne confondez pas ce qui pourrait être normal comme la légère baisse de vitesse de ventilation lorsque démarre la chauffe de la buse ou du plateau.
L'origine n'est probablement qu'un défaut provocant de multiples symptômes.
Un moteur pas à pas avec des problèmes de contact ou de câble peut provoquer des choses surprenante au niveau de la logique et lors du fonctionnement de l'imprimante (pas à l'arrêt par contre).
Pour autant, on commence par des choses basiques avant tout le reste. Vérifiez les tensions, les vis d'alimentation et les câbles de chauffe, plateau et buse.
Ne cherchez pas un problème de chauffe anormal si l'imprimante est à l'arrêt (sans impression)
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
titie3325
Nouveau membre
Messages : 7
Inscription : mar. nov. 29, 2022 9:19 pm
Imprimante 3D : CR10S de 2018

Jacques a écrit : mer. nov. 30, 2022 7:33 am Dans la mesure ou tous les paramètres peuvent êtres modifiés par le G-code, il faut absolument écarter ce problème en utilisant un g-code dont on est certain qu'il ne pose pas de problème (ancien g-code par exemple)
IL est donc important de bien fixer les problèmes avant de continuer.
Si des valeurs changent alors que l'imprimante ne fait rien, c'est un indicateur très important à confirmer.
Un ventilateur qui tourne moins vite sans raison est le signe éventuel d'un problème d'alimentation. Vérifiez votre 12V s'il est bien stable et aussi le 5V qui pourrait provoquer des défauts sur le fonctionnement du processeur.
Le 12v peut perdre au maximum 0,5V au niveau de l'alimentation lorsque la chauffe se met en marche.
Le 5V ne doit pas varier de plus de 0,1v dans tous les cas
Sans défaut manifeste d'alimentation, vérifiez tous les branchements entre l'alimentation et votre carte mère (en particulier les vis de l'alimentation).
Procédez par élimination, logique et confirmez bien les symptômes avec l'état dans lequel est votre imprimante.
Ne confondez pas ce qui pourrait être normal comme la légère baisse de vitesse de ventilation lorsque démarre la chauffe de la buse ou du plateau.
L'origine n'est probablement qu'un défaut provocant de multiples symptômes.
Un moteur pas à pas avec des problèmes de contact ou de câble peut provoquer des choses surprenante au niveau de la logique et lors du fonctionnement de l'imprimante (pas à l'arrêt par contre).
Pour autant, on commence par des choses basiques avant tout le reste. Vérifiez les tensions, les vis d'alimentation et les câbles de chauffe, plateau et buse.
Ne cherchez pas un problème de chauffe anormal si l'imprimante est à l'arrêt (sans impression)
Merci de cette réponse détaillée.
Le G-code que j'utilise est un print que je fais depuis des mois de manière répétée. Elle me fait ces modifications que depuis un mois. Je ne pense donc pas que cela vienne du G-Code il est pour moi sur (suffisamment ancien et utilisé pour que je sois certaine de sa qualité).
Concernant les tensions et câblerie, je n'ai pas vérifié mais je le ferai.
En revanche, mes températures de bed et de buse sont bons (j'ai vérifié), je n'ai que peu de variation sur ces paramètres. Là où elle me fait souvent des modifications c'est sur la vitesse d'impression. L'imprimante augmente ou baisse d'elle même la vitesse sans forcément aller dans le menu tune. Si elle ne faisait que baisser la vitesse je me serai orientée assez facilement vers un problème de chaleur, mais là elle l'augmente également.
La question que je me pose c'est est ce que cela peut venir de la CM ? elle est d'origine sur la machine, et ma machine tourne environ 10h/jour depuis 2018...

je ferai les vérifications ce weekend. Je démonterais intégralement le boitier, nettoyage et vérification sont donc au programme !
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

En fait l'électronique ne s'"use" pas. Tout est régi par l'horloge du CPU. Une panne de ce type reste très peu probable, du moins sur les moteurs pas à pas (moteurs de déplacements et de l'extrudeur).
Une variation du 12v fera varier la vitesse des ventilateurs mais ne changera pas grand chose aux températures qui sont elles régulées. Donc attention à ne pas confondre les symptômes. Un multimètre branché sur le 12V vous indiquera si les variations correspondent à ce que vous ressentez.
Attention tout de même à certains facteurs qui peuvent perturber les moteurs pas à pas. L'imprimante reçoit ses ordres de la carte SD ou de l'interface USB. Il est parfaitement possible que l'USB connecté à un PC puisse causer un tel défaut si l'interface est perturbée par le PC. Par sécurité débranchez l'USB de l'imprimante lors des impression via la SD. N'imprimez pas directement depuis votre PC car un logiciel tiers pourrait perturber l'envoi des données vers l'imprimante. Remarquez que dans ce cas les moteurs pourraient avoir des mouvements saccadés et non une vitesse de déplacement modifiée.
Au final une panne de la carte mère est toujours possible mais ce n'est pas la plus probable. La priorité est de déterminer exactement ce qui vous semble anormal afin de se concentrer sur cette piste et avancer.
Comme souvent, simplifiez au maximum vos dessins imprimés afin de pouvoir plus facilement juger de ce qui n'est pas normal.

N'oubliez pas que le trancheur est capable de ralentir l'impression lors des parties délicates à imprimer et ensuite de reprendre sa vitesse normale. Pour cette raison il faut, soit utiliser un g-code ancien (vieux fichier), soit simplifier au maximum le dessin de la pièce à imprimer afin d'avoir une impression bien régulière. Un cube simple et un cercle simple sont de bons modèles à imprimer car ils offrent un rythme d'impression très régulier.
Par exemple une ligne droite de 20cm, bien que longue, ne sera produite que par une ligne de g-code. Elle ne pourra donc n'avoir qu'une vitesse d'impression. Je veux dire que lors de cette impression de 20cm le moteur doit émettre un son parfaitement régulier.
Si ce n'était pas le cas, on pourrait soupçonner la carte mère mais nous chercherions avant un éventuel "perturbateur", par exemple une multitude d'interruptions anormales causées par un capteur HS. Encore une fois ce type de panne n'est pas, et de loin, la plus courante.
Voilà pourquoi il faut tout simplifier grandement afin d'en rechercher la cause plus facilement.
D'autre part il faut être précis dans les termes employés. Un moteur qui ralenti n'est pas suffisant car un moteur de ventilateur ne fonctionne pas du tout sur le même principe qu'un moteur pas à pas. Il est donc nécessaire d'être très précis dans la description des symptômes.
Plus vous aurez un symptôme franc et reproductible, plus il sera facile d'y remédier.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
titie3325
Nouveau membre
Messages : 7
Inscription : mar. nov. 29, 2022 9:19 pm
Imprimante 3D : CR10S de 2018

Jacques a écrit : jeu. déc. 01, 2022 9:17 am En fait l'électronique ne s'"use" pas. Tout est régi par l'horloge du CPU. Une panne de ce type reste très peu probable, du moins sur les moteurs pas à pas (moteurs de déplacements et de l'extrudeur).
Une variation du 12v fera varier la vitesse des ventilateurs mais ne changera pas grand chose aux températures qui sont elles régulées. Donc attention à ne pas confondre les symptômes. Un multimètre branché sur le 12V vous indiquera si les variations correspondent à ce que vous ressentez.
Attention tout de même à certains facteurs qui peuvent perturber les moteurs pas à pas. L'imprimante reçoit ses ordres de la carte SD ou de l'interface USB. Il est parfaitement possible que l'USB connecté à un PC puisse causer un tel défaut si l'interface est perturbée par le PC. Par sécurité débranchez l'USB de l'imprimante lors des impression via la SD. N'imprimez pas directement depuis votre PC car un logiciel tiers pourrait perturber l'envoi des données vers l'imprimante. Remarquez que dans ce cas les moteurs pourraient avoir des mouvements saccadés et non une vitesse de déplacement modifiée.
Au final une panne de la carte mère est toujours possible mais ce n'est pas la plus probable. La priorité est de déterminer exactement ce qui vous semble anormal afin de se concentrer sur cette piste et avancer.
Comme souvent, simplifiez au maximum vos dessins imprimés afin de pouvoir plus facilement juger de ce qui n'est pas normal.

N'oubliez pas que le trancheur est capable de ralentir l'impression lors des parties délicates à imprimer et ensuite de reprendre sa vitesse normale. Pour cette raison il faut, soit utiliser un g-code ancien (vieux fichier), soit simplifier au maximum le dessin de la pièce à imprimer afin d'avoir une impression bien régulière. Un cube simple et un cercle simple sont de bons modèles à imprimer car ils offrent un rythme d'impression très régulier.
Par exemple une ligne droite de 20cm, bien que longue, ne sera produite que par une ligne de g-code. Elle ne pourra donc n'avoir qu'une vitesse d'impression. Je veux dire que lors de cette impression de 20cm le moteur doit émettre un son parfaitement régulier.
Si ce n'était pas le cas, on pourrait soupçonner la carte mère mais nous chercherions avant un éventuel "perturbateur", par exemple une multitude d'interruptions anormales causées par un capteur HS. Encore une fois ce type de panne n'est pas, et de loin, la plus courante.
Voilà pourquoi il faut tout simplifier grandement afin d'en rechercher la cause plus facilement.
D'autre part il faut être précis dans les termes employés. Un moteur qui ralenti n'est pas suffisant car un moteur de ventilateur ne fonctionne pas du tout sur le même principe qu'un moteur pas à pas. Il est donc nécessaire d'être très précis dans la description des symptômes.
Plus vous aurez un symptôme franc et reproductible, plus il sera facile d'y remédier.
le G-code que j'imprime est un simple godet d'aquarelle... pour lequel au cours des dernières années sur cette meme carte SD je n'avais aucune variation de vitesse...

voici une vidéo du changement de vitesse "automatique" sur ce G-code en question...

je reste persuadée que la carte mère a un problème... je parlais bien d'augmenter la vitesse d'impression nullement de moteur qui accélère ou ralentie. je ne peux etre plus précise.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

En fait je comprends que c'est l'affichage qui indique une augmentation de vitesse.
C'est la première fois que je vois ce problème et ca demande réflexion parce qu'incompréhensible.
En premier lieu je ne chercherais pas une panne mais plus un bug du firmware car l'affichage dépend de lui seul.
Une panne Arduino est toutefois possible mais en fait je chercherais d'autres symptômes un peu identiques pour la confirmer car ce serait une première pour moi.
Vérifiez votre 5V ou tentez d'alimenter l'imprimante depuis votre port USB. Branchez le câble USB à votre PC en plus de l'alimentation normale afin de substituer les 5V imprimante par celui du PC et confirmez votre panne dans ce mode.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
titie3325
Nouveau membre
Messages : 7
Inscription : mar. nov. 29, 2022 9:19 pm
Imprimante 3D : CR10S de 2018

Jacques a écrit : ven. déc. 02, 2022 7:52 am En fait je comprends que c'est l'affichage qui indique une augmentation de vitesse.
C'est la première fois que je vois ce problème et ca demande réflexion parce qu'incompréhensible.
En premier lieu je ne chercherais pas une panne mais plus un bug du firmware car l'affichage dépend de lui seul.
Une panne Arduino est toutefois possible mais en fait je chercherais d'autres symptômes un peu identiques pour la confirmer car ce serait une première pour moi.
Vérifiez votre 5V ou tentez d'alimenter l'imprimante depuis votre port USB. Branchez le câble USB à votre PC en plus de l'alimentation normale afin de substituer les 5V imprimante par celui du PC en confirmez votre panne dans ce mode.
Merci pour cette astuce de vérification. Je vais voir pour tester tout ca ce weekend. je vous dirais quoi.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Sur l'impression d'un cube large on pourrait vérifier si la vitesse moteur change elle aussi à l'oreille (bruit plus ou moins aigu). De plus ca permettrait de confirmer ou d'infirmer une panne que je trouve un peu extraordinaire...
En fait ce paramètre est local, il ne peut pas être changé par le gcode ou le firmware mais seulement au panneau avant de l'imprimante.
Notez que pour certains firmwares la vitesse se règle en tournant simplement la molète (sans cliquer ou passer par un sous menu). Un mauvais contact dans le rotacteur à impulsions du LCD pourrait expliquer un changement de vitesse erratique. Dans ce cas ce serait la carte LCD qui serait à remplacer (ou nettoyer le rotacteur avec une bombe pour contacts)
Vérifiez aussi le connecteur d'alimentation du LCD à la carte mère.

Pour autant ca n'expliquerait pas tout "Que ce soit la vitesse, les températures ou meme la vitesse du ventilo..."
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
titie3325
Nouveau membre
Messages : 7
Inscription : mar. nov. 29, 2022 9:19 pm
Imprimante 3D : CR10S de 2018

Jacques a écrit : ven. déc. 02, 2022 8:42 pm Sur l'impression d'un cube large on pourrait vérifier si la vitesse moteur change elle aussi à l'oreille (bruit plus ou moins aigu). De plus ca permettrait de confirmer ou d'infirmer une panne que je trouve un peu extraordinaire...
En fait ce paramètre est local, il ne peut pas être changé par le gcode ou le firmware mais seulement au panneau avant de l'imprimante.
Notez que pour certains firmwares la vitesse se règle en tournant simplement la molète (sans cliquer ou passer par un sous menu). Un mauvais contact dans le rotacteur à impulsions du LCD pourrait expliquer un changement de vitesse erratique. Dans ce cas ce serait la carte LCD qui serait à remplacer (ou nettoyer le rotacteur avec une bombe pour contacts)
Vérifiez aussi le connecteur d'alimentation du LCD à la carte mère.

Pour autant ca n'expliquerait pas tout "Que ce soit la vitesse, les températures ou meme la vitesse du ventilo..."
quelque soit le gcode la vitesse change et on entend parfaitement ce changement de vitesse au niveau des bruits moteur, je le confirme. Mon imprimante est a proximité de mon bureau de travail, elle tourne tous les jours et c'est en partie a cause du bruit des moteurs que j'ai compris qu'il y avait un problème.
dans mon cas pour changer la vitesse, il faut:
1) appuyer sur le bouton
2) descendre dans le menu à "tune" puis valider en appuyant
3) dans le menu "tune" il faut descendre dans ce menu jusqu'a la partie "speed" appuyer sur le bouton puis modifier les paramètres de vitesse puis appuyer sur le bouton pour valider
4) faire back 2 fois pour revenir à l'accueil ...

sur ma vidéo on voit l'écran d'accueil lors d'un print et on voit bien la vitesse bouger. et malgré tout je ne suis ni en train d'utiliser le bouton ni dans le menu dédié.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Ok, ca infirme mon idée.
A part l'alimentation avec une tension non stable, ou un câble moteur abimé qui perturberait l'électronique, je ne vois pas autre chose.
je vous parle de mon expérience mais avant toute chose de probabilité, pourtant même l'improbable reste possible, le CPU (carte mère)

Tentez tout de même d'alimenter la carte mère par l'USB du PC. Toutes les cartes mères ne sont pas compatibles avec l'alimentation par l'USB. Pour le savoir, il suffit de ne pas brancher l'imprimante au 220 et relier l'USB au PC. Si le panneau LCD réagit, c'est que c'est compatible, l'électronique sera alors alimentée par le 5v du PC et les moteurs par l'alim de l'imprimante.

Pour changer de piste, vous observez la variation de vitesse d'un ventilateur. Si c'est celui qui souffle sous la buse, c'est possible, par contre si c'est celui qui refroidi le haut de buse, ca indiquerait un défaut d'alimentation. En débranchant l'un puis l'autre vous pouvez le déterminer (dans ce cas imprimez sans fil afin de ne pas boucher votre buse)

Câble moteur abimé. Dans ce cas il peut générer des perturbations sur la carte mère et produire des défauts surprenants. Pour faire ce test, il faut débuter l'impression normalement puis débrancher tous les moteurs X,Y, Z, E et observer le LCD durant le reste de l'impression.

Vérification de toutes les connexions électriques afin d'éliminer un mauvais contact générateur de perturbations. En particulier de l'alimentation vers la carte mère et les connexions vers la chauffe buse et plateau.

Probabilités selon moi:
50% problème de connexion
30% alimentation défectueuse
15% surchauffe CPU ou capteur HS
5% carte mère
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Yhan
Nouveau membre
Messages : 3
Inscription : jeu. oct. 26, 2023 5:54 am
Imprimante 3D : En projet

Bonjour,

C'est une approche intéressante pour résoudre ce problème d'augmentation de vitesse sur l'imprimante 3D. En effet, il est judicieux de d'abord explorer les possibilités liées au firmware et aux symptômes similaires avant de considérer une panne matérielle
Répondre