firmware 2.5 Hephestos XL plateau chauffant

Améliorations spécifiques à L'Hephestos 1 BQ et rien d'autre
Serge
Nouveau membre
Messages : 11
Inscription : lun. nov. 26, 2018 9:45 pm
Imprimante 3D : Hephestos XL

Bonjour,

Je me présente, Serge, avec une BQ hephestos ramps 1.4 en format XL et une Tornado chinoise qui m'a donnée envie d'upgrater ma BQ avec un plateau chauffant.
J'ai tout fait il me semble comme dans les super posts du forum => dernier firmware 2.5.1 modifié pour activer le plateau chauffant et compilé avec Make et transféré dans l'imprimante.
Jusque là tout va bien. :ymapplause:

Quand j'imprime un fichier avec une chauffe de lit (qui passe sur ma tornado) il semble que la BQ ignore la consigne de température (voir photo).
Pourtant le GCODE a bien
M140 S35
M190 S35
pourtant je suis bien sur MOTHERBOARD 33 (EFB) dans le firmware

La je sèche ~x( ~x(
Pièces jointes
ecran-prusa.jpg
ecran-prusa.jpg (32.67 Kio) Consulté 11728 fois
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5642
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

M140 c'est plateau chauffant sans attendre la montée en température (c'est votre cas manifestement).
Par contre M190 attend que la température soit atteinte pour continuer avec la chauffe de la buse.

Dans les faits, il faut utiliser surtout au début M190 Sxx afin de confirmer que l'électronique envoi bien l'ordre de chauffe.

Pour le vérifier, il y a une led sur la ramps (de mémoire sous le transistor de puissance repéré led2) qui s'allume si l'ordre de chauffe est lancé sur D8.
Si cette led est éteinte, le plateau ne chauffera pas c'est probablement que le 12V2 n'est pas installé.
12V2 correspond aux deux borniers vert inutilisés à coté de l'entrée 12V de base sur la Ramps (voir carte au dessous avec les deux borniers 12V).
Si la led est allumée sans chauffe, c'est probablement un problème de cablage coté plateau.


Image
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Serge
Nouveau membre
Messages : 11
Inscription : lun. nov. 26, 2018 9:45 pm
Imprimante 3D : Hephestos XL

Bonjour Jacques

J'ai vérifié les branchements et tensions:
- La carte est bien alimentée en 12V1 et 12V2 par une alim puissance 12V
- le plateau chauffant est bien connecté en D8
- La sonde température du plateau fonctionne => avec un sèche cheveux sur le plateau la température affichée sur le LCD monte :cheese:

Quand le lance l'impression :
- il y a une tension en sortie D10 et D9 mais rien sur D8 :?
- L'impression se lance directement sans faire d'action sur le plateau.
- Seul les led 3 et 4 s'allument qui doivent correspondre à la buse et ventilo
- Sur l'affichage LCD j'ai toujours une température de consigne temperature plateau de 0 degré :((

Voici le fichier purgé que j'ai utilisé pour les essais
Pièces jointes
2018-11-28_09h49_11.png
2018-11-28_09h49_11.png (19.58 Kio) Consulté 11702 fois
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5642
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Si vous avez sur le LCD 15/0 ca sous entend que votre plateau ne chauffera pas, le 0 étant la consigne demandée.
Dans ce cas ne cherchez pas au niveau de l'électronique, ca n'est pas utile pour le moment
Testez votre plateau avec des commandes directes depuis l'interface Cura ou autre pour déjà allumer la led2 qui correspond plateau.
Isolez au maximum les choses, ce sera plus facile pour avancer
Tentez un nouveau firmware comme celui d'un plateau court il y a peut-être un problème sur celui du plateau long
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Serge
Nouveau membre
Messages : 11
Inscription : lun. nov. 26, 2018 9:45 pm
Imprimante 3D : Hephestos XL

Bonjour Jacques

Je penses que j'ai trouvé la solution.
Il s'agissait d'un problème de firmware dans les modifs que j'ai faites:

Il faut activer le capteur du plateau(temp-sensor)
mais j'avais oublié d'activer l'action du plateau chauffant (bed-support)

Maintenant la consigne de température est bien reconnue sur l'écran LCD, que ce soit des fichiers venant de Cura ou Simplyfied 3D.

Plus qu'a finaliser la connection complète du plateau chauffant avec un relai de voiture (5€ à norauto).
Je posterais le plan des branchements electriques avec le relai pour ceux que cela interesse.
Pièces jointes
capteur.png
capteur.png (6.38 Kio) Consulté 11674 fois
bed-support.png
bed-support.png (6.11 Kio) Consulté 11674 fois
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5642
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Cette dernière valeur n'est pas présente sur toutes les versions mais dans ce cas indispensable, bravo !
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Specter_03
Contributeur actif
Messages : 183
Inscription : mar. avr. 28, 2015 11:26 am
Imprimante 3D : Prusa i3 Hephestos

Bonjour :shy:
Votre modif m’intéresse :) je suis aussi avec une Hephestos 1 modifié en XL, et je cherche depuis un moment les bon composant pour le plateau chauffant.

si vous pourriez détaillé un peux ce que vous avez du acheté et ou ça serais avec grand plaisir :)

Niveau Frimware, faut que je check, je suis avec Marlin 1.8, j'ai abandoné BQ depuis un ptit moment déjà pour pouvoir profité du BLTouch :)
Serge
Nouveau membre
Messages : 11
Inscription : lun. nov. 26, 2018 9:45 pm
Imprimante 3D : Hephestos XL

Voila le montage de mon hephestos XL avec plateau chauffant est finalisé et tout fonctionne aux petits oignons :saturdaynight: :saturdaynight:

Les transformations du fichhier config.h sont finalement simple :goodguy: :

#define HEATED_BED_SUPPORT
(avec les options BED_SUPPORT activées du précédent post le plateau chauffait en permanence sans s'auto réguler)

#define TEMP_SENSOR_BED 1

Pour la réalisation, j'ai utilisé un simple relai voiture universel (5€ chez norauto) pour que la board n'alimente pas en directe le plateau chauffant.
J'ai essayé de faire un schéma de branchement le plus complet possible pour s'y retrouver au niveau du relai :senpai: :peace: (les ventilos ne sont pas représentés mais il n'y a rien à modifier).

Après c'est plus une gestion des cables pour éviter les sacs de noeuds :medievil: :evil:

Bonne réalisation (la bidouille n'est pas si compliqué qu'il n'y parait). :shy: :shy:
Pièces jointes
LCD.jpg
LCD.jpg (59.08 Kio) Consulté 11639 fois
ARRIERE.jpg
ARRIERE.jpg (104.89 Kio) Consulté 11639 fois
RELAI.jpg
RELAI.jpg (79.5 Kio) Consulté 11639 fois
MONTAGE -PLATEAU.png
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5642
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Belle réalisation qui fonctionne peu importe le plateau, 12 ou 24V, 100 ou 150 W.
Il y a aussi le même montage avec un relais électronique qui a l'avantage d'être plus silencieux.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Specter_03
Contributeur actif
Messages : 183
Inscription : mar. avr. 28, 2015 11:26 am
Imprimante 3D : Prusa i3 Hephestos

Merci pour ces infos :)

Si tu as encore les liens des produits que tu as acheté je prend aussi :D
Serge
Nouveau membre
Messages : 11
Inscription : lun. nov. 26, 2018 9:45 pm
Imprimante 3D : Hephestos XL

Bonsoir Jacques

Effectivement le relais voiture fait un petit bruit de type "TAC-TAC" mais la température du plateau est super bien régulée +/-1°c . C'est plutot le ventilo de l'alimentation chinoise qui fait le plus de bruit. :silence:

Sinon c'est intéressant d'avoir des renforts latéraux sur l'arriere de l'imprimante car cela permet de relever les cables alimentant le plateau pour qu('ils ne se prennent pas dans le moteur arrière de l'axe Y (voir photo).

Avec la chauffe les impressions sont de meilleures qualités notamment sur le PETG /plateau à 80°C (voir photo). Comme si le plateau réchauffait l'air autour de la pièce à imprimer avec une meilleure adhésion entre couches (c'est mon interprétation).

Specter, je n'ai pas les liens car c'est des pieces que j'avais achetées il y a plusieurs mois sans prendre le temps de faire le montage...
mais j'ai pris : Alim 12v-30A, plateau chauffant MK2, thermistance 100k, relais voiture universel, fil électrique de recup...

Bonne réalisation
Pièces jointes
plateau-renfort.jpg
plateau-renfort.jpg (138.7 Kio) Consulté 11605 fois
marvin2.jpg
marvin2.jpg (135.04 Kio) Consulté 11605 fois
marvin1.jpg
marvin1.jpg (109.43 Kio) Consulté 11605 fois
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5642
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Si c'est un MK2 200x200 et une alim 12V on a ca en stock https://boutique.premium-computer.fr/sh ... stosprusa/

Maintenant, il est clair que le plateau chauffant offre une meilleure adhésion des pièces au plateau. L'ambiance chaude se répercute sur les autres couches ce qui renforce certainement la cohésion des couches.
Le relais peut être remplacé par des transistors mosfet afin d"éviter le bruit
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Specter_03
Contributeur actif
Messages : 183
Inscription : mar. avr. 28, 2015 11:26 am
Imprimante 3D : Prusa i3 Hephestos

Merci pour les réponses.

Non malheureusement je suis en 200x300 (version XL) c'est pour cela que je c'est pas trop quoi prendre comme plateau chauffant.
Serge
Nouveau membre
Messages : 11
Inscription : lun. nov. 26, 2018 9:45 pm
Imprimante 3D : Hephestos XL

Bonsoir Specter

Concernant le lit chauffant, il s'agit d'un lit MK2a PCB HEATBED environ 200*300 en 12v.
Mais tu peux également le prendre en Alu.
Il y a plein de vendeur le net (voir banana 3.14159).

J'ai isolé le lit chauffant par le dessous avec du liège mais je constate qu'il ne monte pas au dela de 85°C. Cela me permet quand même d'imprimer de l'ABS, mais je pense que c'est peut être aussi à cause de l'alim en 12v.

Sinon pour intégrer le lit chauffant correctement et me faciliter la vie pour le "bed leveling", je me suis débarrassé du lit d'origine en PE noir qui était voilé :yarrrrr: et j'ai fabriqué un cadre ultra léger en profilé Alu 15*10mm (leroy merlin)qui est connecté aux vis de réglage et vide au centre( pour mettre isolation).
J'ai aussi enlevé l'épaisse plaque de verre pour mettre un simple miroir.

Bon montage
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5642
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Si le plateau ne monte pas au dessus de 85° c'est aussi qu'il se refroidit trop. Augmentez l'isolation sous le plateau.
Vérifiez aussi la tension au bornes du plateau, 11V est le minimum et ca suppose aussi que les fils et le relai perdent 1V, soit environ 15W, ce qui est déjà énorme (1V X 15A = 15W).
Limitez les longueurs de fils et augmentez les sections afin de faciliter le passage du courant.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Répondre