Problème capteur inductif Hephestos 2 et Witbox 2

Exposez ici vos problème techniques matériels
Répondre
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Le détecteur inductif H2 et W2 est une carte avec un µP ARM Cortex M0 , un contrôleur d'inductance LDC1000 et un TCN75AVUA charger de compenser la température ambiante afin d'avoir une détection plus précise. Une bobine est intégré au CI (partie ronde du CI) et un crystal 8Mhz cadence le tout.
Une led rouge s'allume lorsque la détection se fait.

On a tous constaté que cette détection est assez relativement précise mais que surtout elle se dégrade avec le temps.
J'ai donc effectué des mesures de détection du plateau. J'arrive à une erreur max de +/- 30µ, ce qui est suffisant pour une impression à 200µ mais bien moins satisfaisant à 100µ, et ne parlons pas de 50µ...

Bien, on va rester sur la base 200µ.
On note des variations de positionnement du Z de plus de 200µ, ce qui fait que de temps à autre la pièce se décolle ou que la buse est trop basse suivant le réglage de l'offset.
J'ai donc commencé par vérifier le moteur plateau sur ma W2. Sa précision de monté/descente est de +/- 1µ. L'écart entre monté et descente est de -1µ.
Ces résultats sont excellents et doivent offrir une excellente impression de parois verticales (je n'arrive pas à si bon sur une W1 avec moteur couplé à la vis Z)
Bref, au niveau mécanique il n'y a strictement aucun problème, le 0 électronique est toujours à la même hauteur mécaniquement.

On a donc une mécanique parfaite et un détecteur moyen mais dont les défauts constatés ne sont pas suffisant pour créer un véritable problème autre qu'une base +/- parfaite

J'ai donc décidé de contrôler l'effet de la détection à 20° puis avec la buse à 200°.
A 20°, comme noté plus haut la reproductibilité est de +/- 30µ
Une fois que la température monte, cette erreur passe en quelques minutes de +/- 30 à 170µ + +/- 30µ mais globalement toujours positivement, le plateau s'écarte inexorablement de la buse.
Pour autant, la température du CI ne passe que de 20 à 30°, ce qui n'est pas énorme comme écart et de plus devrait être compensé par le chip à cet effet.

Soit la compensation en température est mal faite, soit c'est autre chose comme je l'avais déjà imaginé, le circuit imprimé se déforme avec la température. Pour autant, fixé par deux vis c'est peu probable d'avoir autant d'erreur avec 10° d'écart de température.
Je démonte donc la carte avec l'idée de l'isoler de la buse avec un isolant thermique afin que l'impact de la buse chaude ait moins moins d'effet sur le CI de mesure température et sur le capteur inductif en lui-même.

Si vous regardez, cette carte est fixé au châssis sur deux supports en alu et deux vis fraisées qui s'encastrent dans la carte afin de ne pas dépasser dessous, c'est à dire ne pas risquer de toucher à la pièce en cours d'impression.
Si l'on regarde de plus près, on constate que les vis fraisées ne serrent que les supports rond en alu. Ce n'est donc pas les vis qui fixent CI et support au chassis.
En regardant d'encore plus près, sur le support proche de la bobine d'induction, j'ai constaté une fissure dans le sertissage. En touchant le support je me suis aperçu que celui-ci peut bouger dans le circuit imprimé, et donc se rapprocher du plateau d'environ 2 à 300µ sans forcer.
On a donc un circuit qui ne se trouve fixé que par un seul sertissage et offre un porte à faux au capteur de plus de 5cm, ce qui explique alors l'effet que peut avoir la chaleur sur la précision du 0 à chaud. La carte en verre epoxy recouverte de couches de cuivre se tord avec la chaleur.
Inductif decollement.JPG
Inductif decollement.JPG (46.56 Kio) Consulté 1258 fois
J'avais déjà constaté que ces supports se décollaient du CI mais je supposais que les têtes de vis bloquaient l'ensemble. Il n'en est rien, le trou sur le CI est plus gros que la tête de vis ! Le sertissage est donc super important.
J'ai donc décidé de coller les deux supports au CI avec de la colle époxy dans l'attente de trouver une très fine rondelle à ajouter aux vis fraisées afin de bloquer l'ensemble au vissage.
On peut facilement imaginer qu'à force de taper sur des pièces décollées ou sur le plateau, le sertissage finit par désolidariser le circuit du support.
Inductif 2.JPG
Inductif 2.JPG (70.72 Kio) Consulté 1258 fois
Donc, si vous avez le même problème de O instable, démontez votre carte, il est très probable que vous ayez la même chose, ou même pire.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Aux tests le résultat est bien meilleur mais reste qu'il semble que la température ambiante a toujours une influence directe sur le 0.
J'ai donc soit une compensation en température qui ne fonctionne pas correctement, soit un autre problème car il n'est pas normal d'avoir un résultat variable de +/- 30µ entre deux mesures au même moment.
Par acquis de conscience je vais regarder la carte au microscope afin de voir si un composant n'aurait été dessoudé de cette carte qui n'a aucune protection mécanique.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Je n'ai rien découvert sur le circuit imprimé, le problème n'est donc pas là.
Par contre, l'imprimante mise en marche à 19° se cale sur un 0 très bas (première couche écrasée).
Je reprends mes mesures au comparateur, on a toujours une erreur de +/- 30µ entre deux 0 mais le changement véritable c'est que la machine est complètement froide.
Je monte la température à 210 et durant la phase de monté, je mesure la hauteur du plateau depuis le haut du châssis de l'imprimante avec des remises à 0 Z successives et des mesures.
L'effet est immédiat, dès le tout début de la monté en température (quelques secondes), je constate que le plateau baisse de plus en plus pour arriver à - 0,4mm après 30 secondes de chauffe.
La sonde de température ne fait pas son effet, ou plus justement, elle n'arrive pas à aller aussi vite que la réaction du capteur à la chaleur.
Bien entendu, le chip en plastique qui contient la sonde n'a pas une réactivité assez rapide alors que le capteur inductif réagit immédiatement à la température de l'air.
On arrive donc à un défaut bien plus important que lorsque l'imprimante est globalement chaude. C'est aussi ce qui expliquerait la difficulté du réglage de l'offset machine froide.
Lors de mes précédents tests, la machine était toujours plus ou moins chaude ainsi que la sonde du chip, le défaut constaté ne dépassait alors pas 0,2mm. C'est donc que la sonde a bien une action de correction mais n'est de loin pas assez rapide pour compenser une monté rapide de la buse en température.
Donc la solution réside en fait à isoler la buse du détecteur afin qu'elle le perturbe le moins possible.
Je mets donc un scotch vertical entre la sonde et la buse. Le résultat est probant, l'écart de hauteur devient alors bien moins important lors de la phase de chauffe.
Pour autant, la solution n'est pas évidente à trouver. Pour mémoire, la prise du 0 se fait lors de la première phase de monté en température alors que le réglage de l'offset se fait imprimante plus ou moins chaude....
En réalité le problème est que l'imprimante refait un 0 à chaque impression et donc suivant le cas une mesure bonne ou fausse avec une température du capteur qui est possiblement différente de celle de l'air ambiant.
Le détecteur a été probablement dessiné et testé sur un banc de tests contrôlé en température mais sans la proximité d'une buse pour perturber gravement son fonctionnement.


Le truc à trouver c'est comment faire pour avoir une mesure dans de bonnes conditions, probablement souffler de l'air ambiant sur le chip sonde, le détecteur, le plateau en direction de la buse afin de ne pas être influencé par la chaleur rayonnante de la buse.

Pour ne rien vous cacher, je viens de confirmer pourquoi je préfère l'usage d'un bon vieux micro switch, précis et surtout fiable.

A suivre.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Tout ca ne me convient pas trop, je vais donc reprendre des mesures répétitives du 0 à froid afin de bien préciser la précision de base du capteur. En fait, j'ai regardé la doc technique du chip sensor et me suis aperçu que sa précision de distance de détection variait de +/- 15% sur une plage de température de -20 à 70°. Si sa détection de base à 20° et de 8mm, on aura à 70° une détection qui pourra varier jusqu'à plus 1mm ce qui est énorme.
Alors, bien entendu nous avons la sonde qui va rectifier la mesure mais ce qui me gène c'est que la sonde n'aura jamais la réactivité de l'air ambiant....

Du coup, j'ai repris mes mesures à 18° en faisant des remises à 0 consécutives et en mesurant la hauteur du plateau.
La courbe ci dessous donne un résultat qui est variable sur une plage de 71µ, ce qui est relativement important quand même. Selon cette série de mesure on ne sera pas capable d'imprimer à 100µ !!!
La courbe à tendance à montrer une baisse globale du plateau dans le temps qui je pense est liée à l'élévation de la température interne de l'imprimante (power, ect)
Var 0 a froid.JPG
Var 0 a froid.JPG (36.77 Kio) Consulté 1193 fois
A la suite de ce test, je me suis mis à souffler de l'air chaud sous le détecteur au moment de la détection pour voir ce qui se passe.
On retrouve la courbe initiale suivit de mesures avec mon souffle sous le détecteur.
Var 0 souffle chaud.JPG
Var 0 souffle chaud.JPG (32.88 Kio) Consulté 1193 fois
L'effet est immédiat, on passe de -28 à -218 , 0,2mm d'écart !!!
Ensuite le plateau remonte avec une erreur de moins en moins importante. L'explication est simple, la sonde du dessus commence à compenser la température. je l'ai vérifié en faisant une pause de quelques minutes, l'erreur maximum revient invariablement puis la compensation réagit à nouveau pour limiter l'erreur.

Bref, je ne vois pas comment, même avec un capteur compensé, avoir une température suffisamment constante afin que le 0 soit bien toujours à la même hauteur. Le seul moyen serait d'avoir un autre capteur inductif qui servirait de référence à la mesure du premier.
Ce serait alors une usine à gaz pour un résultat somme toute très peu précis et en tous les cas bien moins précis qu'un simple micro switch
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Dans la mesure ou la tête bouge lors de la prise du 0, ne serait-ce que déplacer le détecteur pour se mettre sous la tête (décalage configuré dans le firmware afin de mesurer l'endroit ou se trouve véritablement la tête) il y aura nécessairement de l'air qui va être brassée et notre mesure ne sera jamais dans une atmosphère stable nécessaire à cette mesure.
Je suis persuadé que si la mesure était faite en statique nous aurions un résultat en peu plus précis.
J'ai donc débranché tous les moteurs sauf le Z, mis du sopalin autour de la tête, machine complètement fermée afin de n'avoir aucun courant d'air et le résultat est encore meilleur, j'arrive par moment à avoir des séries de +/- 3µ et même de 0 !

Sachant qu'en théorie ce système est parfait mais qu'on mesure l'endroit précis ou la tête a chauffé le plateau, avec le courant d'air du déplacement de la tête, les courants d'air de la pièce, les ventilateurs qui brassent du chaud et du froid, on est loin d'une température stable...

je crains qu'il ne soit définitivement pas possible d'utiliser cette technologie pour le réglage précis de notre 0 ou de l'auto-leveling qui utilise le même capteur pour compenser la planéité de notre plateau.

Je ne vois qu'une solution, travailler avec une température la plus constante possible et laisser un temps de stabilisation à chaud avant de lancer une impression ou de régler l'offset. Sur la W2, fermez toujours la porte et installez le plexi du dessus.

C'est un constat qui ne me fait pas plaisir mais c'est ainsi, proche de la source de chaleur il ne sera jamais possible de compenser dynamiquement une température que l'on mesure d'une part avec un chip (inertie et hystérésis) et d'autre part avec le capteur sur une surface nécessairement chaude (il y avait la buse l'instant d'avant) et le tout en bougeant la tête...

Après, la solution ultime sera de faire comme moi, installer un switch et supprimer l'autolevel qui n'offre d'ailleurs aucun intérêt pour celui qui a un peu d'expérience.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Pour être très précis en réalité dans mon dernier constat je ne sais pas qui réagit si brutalement au souffle d'air chaud. Est-ce le capteur ou la sonde, en fait je ne sais pas faire la part des choses car lorsque je souffle sur le capteur, l'air chaud va aussi sur la sonde.
J'ai donc regardé la réactivité du chip sonde sur les spécifications constructeur. Entre 27° et 125° il ne lui faut que 2 secondes pour mesurer 100° et pour monter à 45° 0,2 s. Les données du constructeur ne montre aucun temps de retard dans la courbe qui monte immédiatement dès que la variation de température est appliquée. Comme toute mesure de température, une sonde ne peut mesurer instantanément une variation avec précision. Il y a d'une part un retard (le temps de chauffer l'enrobage isolant du capteur, en l'occurrence le boitier du chip), et le temps pour chauffer la masse de l'élément capteur. Pour autant celle-ci est capable de n'avoir aucun retard et donc de réagir immédiatement à une variation qui dans mon cas dure entre 1 et 2 secondes, de quoi largement influencer la mesure du capteur inductif.

J'ai donc pris une paille afin de ne souffler que sous le capteur en évitant donc la sonde qui se trouve au dessus de la plaque.
En fait ce souffle chaud ne fait que mettre de l'air chaud temporairement entre le plateau et le capteur sans changer la température du verre ni celle du circuit.
Dans ce cas mes mesures ne changent plus véritablement, je ne retrouve plus l'écart si important qu'en soufflant sur l'ensemble.
Il faut donc croire qu'en fait c'est la sonde qui réagit très fortement en premier.
Une dernière possibilité serait que le rayonnement infrarouge de la buse aurait un effet sur le chip de température avant même que la température ambiante n'ait un effet sur la distance de détection.

Il me reste donc à créer une barrière mécanique entre la buse et le chip destinée à protéger le chip du rayonnement infrarouge pour ne mesurer que la température de l'air.
Il faut donc que je dessine une pièce qui va se glisser sur la plaque du capteur pour créer une "ombre" à l'infrarouge.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

J'ai donc réalisé une barrière au rayonnement directe sur la sonde du capteur.
Cache sonde.JPG
Cache sonde.JPG (50.23 Kio) Consulté 1160 fois
Je suis ensuite parti d'une imprimante froide. Mesures à froid (18° interne) toujours les mêmes valeurs de décalage +/- 30µ.
Puis j'ai lancé la chauffe et le décalage à recommencé de la même manière qu'avant, plus la chauffe dure, plus le plateau descend dans les mêmes proportions qu'avant.
Après une heure de chauffe, l'imprimante est à 21° et là, chauffe ou pas, les résultats sont relativement stables.
A croire donc que l'enceinte même a une importance sans pouvoir déterminer si c'est la sonde qui réagit et compense (mal) ou le capteur qui détecte plus moins loin en fonction de la température.
Le résultat est donc qu'à une température interne moyenne on peut avoir un offset à peu près constant. Cependant, à l'usage c'est bien trop compliqué car la moindre impression demande d'attendre au moins une heure pour imprimer sans devoir changer l'offset. Le pire, si je n'attends pas c'est que lors de chaque réglages de l'offset le décalage augmente. Je veux dire que s'il y a 0,1mm de trop, je mets alors -0,1, je fais une nouvelle mesure et je suis toujours trop haut de 0,1mm. Pourtant, selon mon comparateur la nouvelle valeur de l'offset a bien diminuée de 0,1mm.
Ca devient en fait un cercle vicieux, plus je chauffe, plus ca change, insoluble finalement...

Tout ce temps passé pour pas grand chose ...
Il ne me reste qu'à prendre le temps de tester l'ensemble détecteur à l'extérieur afin de tenter de comprendre ce qu'il se passe en fonction de la température.
Bref, il me faut un peu de courage pour au final en arriver à passer sur un switch mécanique bien plus précis que ce détecteur compensé dont je ne sais pas comment fait est le firmware. J'ai tout de même un gros doute sur le développement de la correction qui a du être réalisé sur un banc et non en situation réelle.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

J'ai donc dessiné et imprimé des pièces afin de tester la capteur inductif sur banc (loin de la buse)
Banc capteur.JPG
Une alimentation, un comparateur couché avec un morceau de métal sur le bout opposé, une vis et un ressort chargés de régler la distance entre le métal et le capteur.
Détail banc.JPG
Détail banc.JPG (45.66 Kio) Consulté 1131 fois
Au passage, en rouge, le chip qui mesure la température pour corriger l'erreur d'offset.

Bref, la détection se fait à 8mm de distance du capteur, ce qui correspond aux performances d'un capteur rond de 12mm de diamètre. Notre bobine est dessinée sur la face basse du CI qui mesure 15mm de diamètre mais la bobine ne fait que 12 ou 13mm.
L'hystérésis de détection (écart entre détection et relâchement) est de 6 à 7µ, ce qui est très bien pour le réglage de planéité.

Mes tests :
En fait à 19° j'ai toujours une variation au maxi de +/- 15µ, ce qui est meilleur que lorsqu'elle est montée sur l'imprimante (+/-30µ).
A 20° j'ai déjà une différence de détection de l'ordre de 50µ
Mais ce qui est plus remarquable c'est que je dois ne plus respirer afin d'avoir des mesures stables. En effet, si mon souffle va sur le capteur, l'erreur peut alors aller jusqu'à 200µ.
Pour le coup, j'ai bien isolé la sonde de température du capteur. La sonde n'a que très peu d'effet sur la distance de détection. Par contre le circuit imprimé chauffé change gravement la distance de détection. Est-ce, la température de l'air, la température du CI, de la plaque en métal ou encore l'hygrométrie ?
Pour en avoir le cœur net, j'ai chauffé une pointe de couteau que j'ai posé sur le ci quelques secondes puis repris le mesures. Je trouve alors une erreur de 400µ, ce qui est énorme. Même test sur la pièce en métal cible, sans effet.
Donc, ce n'est ni le chip de température ni la température de l'air, ni l'hygrométrie, ni la température de la pièce cible mais bien la température de la minuscule bobine imprimée sur le circuit imprimé qui réagit très fortement avec la température. Sa masse est tellement faible et le vernis dessus si peu épais, que son inertie thermique est ridiculement faible, elle réagit immédiatement à la chaleur en modifiant très significativement la distance de détection et donc le 0 Z.

J'avance donc, je sais maintenant la sonde thermique n'est pas très réactive et ne mesure que la température ambiante. Donc sa correction ne pourra agir que dans une ambiance calme, ce qui est loin d'être le cas avec la buse chaude à proximité, le plateau chauffé à l'endroit de la mesure, le courant d'air des ventilo en action et de la tête qui bouge...
J'ai tout de même ajouté une mousse d'1mm sur le circuit imprimé (on peut le voir sur ma photo) afin d'obtenir plus de stabilité thermique. Maintenant, si je souffle sur le ci, il ne se passe plus rien, la mesure reste la même (à condition de ne pas trop insister tout de même).

Compte tenu de la sensibilité du capteur, j'ai aussi fait une mesure en fonction de l'alimentation. De 5v je suis passé à 5,1v ce qui me change la détection de 200µ !
Vous me direz, pourquoi ce test ? Simplement parce que des variations de tension il y en a nécessairement avec la buse qui chauffe par impulsion et donc une charge très variable qui entrainera nécessairement une variation du 12V et par incidence celle du 5V

Je vais de ce pas faire les mesures du 5V en chauffe.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Je dois reconnaître que l'alimentation BQ est bien faite, j'observe une variation de 1,3 mv lors de la régulation de la chauffe, ce qui n'est pratiquement rien et doit correspondre à une différence de 1 ou 2µ lors des mesures du 0. Pour bien faire il faudrait aussi faire fonctionner les moteurs et regarder le ripple de l'alim avec un oscilloscope pour être certain que tout est parfait à ce niveau.
Cependant, cette vérification est nécessaire pour tout ceux qui se plaignent d'un 0 variable, mon résultat n'est pas nécessairement le votre, 100mv correspond à 200µ, une paille !

Reste donc, dans mon cas la température du circuit imprimé qui est très réactif à l'ambiance. Donc mesurer le plateau à l'endroit même ou la buse a chauffé le verre, n'est pas une bonne idée.
J'ai donc collé un morceau de mousse sous le circuit afin de limiter le transfert de chaleur au moment de la mesure.
Il n'y a plus qu'à tester en situation
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Selon le schéma BQ du circuit inductif la bobine est imprimée sur la face du dessous mais une autre se trouve sur le dessus, j'ai donc l'explication sur la réactivité du chip de température. En chauffant le chip qui se trouve au dessus, je chauffe aussi le circuit. Et c'est ce circuit qui lui aussi perturbe le capteur.
J'ai donc besoin d'isoler les deux faces du capteur afin qu'il ne réagisse pas de manière instantanée à un courant d'air chaud ou froid.
Reste qu'en montant gentiment la température ambiante, à 18° j'ai une mesure qui va changer pour passer à -50µ pour 19°, -100µ pour 20° et 180µ pour 22°.
Malgré la compensation de température, il ne semble pas possible d'avoir une stabilité de détection. En fait, plus il fait chaud, plus le capteur détecte loin le plateau.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Ce matin, 17°, je suis à 150µ mais cette valeur change rapidement pour arriver à 80µ sans raison apparente. Sauf qu'en cherchant je comprends que la carte chauffe simplement par la dissipation des chips après sa mise sous tension. Le chip contrôleur passe de 17 à 21° en quelques minutes, ce qui a pour effet de chauffer le circuit imprimé qui monte gentiment à 19° alors que la température ambiante n'a pas changé. Après une heure de "chauffe" statique on se stabilise à 50µ

Finalement tout a une influence sur tout et c'est cette complexité qui donne alors le coût de développement et donc le prix final. Ce type de capteur ne pourra jamais offrir un résultat précis car il y aura toujours une différence entre la température de la sonde chargée de compenser la mesure et celle du circuit de la bobine. Ce ne sont pas les mêmes matériaux, pas exactement au même endroit et n'offrent pas non plus la même inertie thermique. Dans un contexte perturbé comme nos imprimantes (buse, ventilateurs, mouvements), cette technologie n'est simplement pas adaptée ou alors serait bien trop couteuse ou contraignante à mette en œuvre. En fait, pour faire une simple mesure de 0 il faudrait le faire à froid, couper les ventilateurs et ne plus bouger la tête quelques instants avant de mesurer. Un 0 avec palpation de plateau devrait prendre une dizaine de minutes à condition de le faire avec une buse froide depuis déjà quelques dizaines de minutes.
Si je dois prendre un exemple pour confirmer mon constat, La Prusa MK3 est équipé d'un capteur classique avec une capsule en plastique et une sonde de compensation. Prusa a ajouté en plus un réglage dynamique manuel du 0, preuve qu'il n'arrivent pas à une stabilité suffisante rein qu'avec le capteur inductif.

Maintenant, si je dois faire une synthèse pratique, BQ a fait une erreur lors de la conception du capteur. Contrairement aux autres capteurs inductifs, celui de BQ ne comporte pas la capsule en plastique habituelle qui offre l'avantage d'isoler la bobine des variations brutales de température contextuelle. C'est d'autant plus important dans notre cas que la buse chaude est très proche.
En isolant avec une mousse le circuit imprimé, j'ai donc des mesures qui sont biens plus stables et précises qu'avant. Il est donc nécessaire de faire cette modification.
N'ayant pas la possibilité de savoir comment se comporte la sonde dans un contexte donné et la correction qu'elle apporte, je dois me résoudre à tenter de limiter l'effet des perturbateurs thermiques avec de simples isolants qui pourront absorber toutes les variations brutales, tout en conservant la correction de la température ambiante. La question maintenant c'est de déterminer l'épaisseur de l'isolant nécessaire afin de conserver l'accord dynamique temporel entre sonde thermique et sonde inductive afin d'obtenir le meilleur résultat.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

La détection inductive
La bobine tank (le circuit de mesure inductance) est d'un diamètre de 14mm et comporte 24 spires sur les deux faces du circuit imprimé (documentation Texas Instruments)
Tank.JPG
Tank.JPG (47.59 Kio) Consulté 1082 fois
Le fil (circuit) de cuivre mesure donc environ 50µ X 200µ, autant dire que ce fil est très fin et donc très vite influençable par la température de l'air.
Plus la température de cette bobine augmente, plus la distance de détection augmente.

Sonde thermique
La sonde de température est chargée diminuer la distance de détection si la température augmente. Je l'ai vérifié c'est bon, son action est très efficace mais sa réaction est relativement lente (plusieurs secondes)

Compensation
L'un compense en effet l'autre pour avoir une mesure de distance la plus exacte possible.

Problématique
Le problème c'est que les deux ne réagissent pas à la même vitesse d'où des écarts mesurés qui peuvent largement dépasser 0,4mm en moins d'une seconde selon l'environnement.

Un isolant en plastique de 2mm entre le capteur et l'objet métallique à détecter ne change pas la distance de détection. On peut donc isoler le circuit sans nuire à sa performance tout en étant limité par la distance de 4mm entre la capteur et la base d'impression. Si l'on ne veux pas risquer de toucher la pièce en cours d'impression, le mieux serait de ne ne pas dépasser 2mm d'épaisseur sur la partie basse du circuit.

Je vais donc fabriquer une pièce qui va s'insérer dans le circuit avec deux morceaux de mousse afin de l'isoler des perturbations thermiques ambiante.
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

La réalisation
Un couche dessus, une autre dessous et le tout dans une pièce imprimée qui se glisse entre le circuit imprimé.
Calfeutrage tank.JPG
Calfeutrage tank.JPG (84.03 Kio) Consulté 1072 fois
Calfeutrage final.JPG
Calfeutrage final.JPG (89.26 Kio) Consulté 1072 fois
Il faut faire attention à ne pas arracher le petit condensateur C_tank avec la mousse qu'il faut découper.
La sonde thermique (chip) est recouverte d'un cache en plastique, ce sera probablement une variable d'ajustement de la réactivité.

Les tests
Il s'avère que le réglage de l'offset se fait d'une manière probante. Premier temps je règle celui-ci de manière empirique avec la buse qui perd du plastique. Ensuite un essai d'impression et ensuite finalisation du réglage selon la mesure de la première couche au pied à coulisse.
Résultat impeccable, je ne reprends plus l'offset.
Impression de 10 fois la première couche, ca colle mais on reste loin d'un switch, il faudra surveiller et recommencer de temps à autre.
Impression 1h d'une pièce
La machine est maintenant à 28°
Je relance une nouvelle impression mais la buse est maintenant un peu trop haute, la pièce ne tiendra pas.
La compensation en température n'est donc pas assez efficace. Je peux retirer le plastique dessus mais je crains que ce ne soit pas suffisant car la monté en température a été progressive et mon capot (non isolé) ne change en principe rien à la mesure de température.

Bref, tout ca pour en arriver à bien mieux, mais ca reste imparfait pour moi du moins.
Avec mon Hephestos et mes W1, je fais 95% de mes impressions sans retoucher quoi que ce soit et sans devoir recommencer.
Si j'ai besoin de quelque choses de parfait, il me suffit alors de niveler mon plateau.
Avec la W2 ca reste un peu du hasard, on lance et on observe. Si c'est pas bon on recommence...
Ou alors il faut régler un offset plus bas et accepter une première couche de temps à autre écrasée.
Ce n'est définitivement pas pour moi
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Avatar de l’utilisateur
Jacques
Site Admin
Messages : 5605
Inscription : jeu. oct. 23, 2014 3:02 pm
Imprimante 3D : Witbox, Witbox 2 et Hephestos
Localisation : Aix en Provence
Contact :

Après relecture de ce sujet, je me rends compte que l'une des erreurs de BQ, c'est d'avoir monté la bobine sur le même circuit que le contrôleur qui chauffe et influence directement la bobine mais aussi le capteur thermique. C'est une différence notable avec les capteurs inductif ronds du commerce où la bobine est reliée au circuit de détection par des fils. Idem pour la sonde de température qui devrait se trouver à coté de la bobine et non à coté d'une source de chaleur. En fait, même avec une compensation, cet ensemble non isolé est bien trop influençable par une ambiance thermique qui n'est absolument pas stable.
Je pense en fait que les techniciens de BQ ont simplement repris le schéma Texas Instrument pour l'adapter à un circuit horizontal plus facilement logeable dans l'imprimante.
Comme quoi, à ce niveau de précision, il est très compliqué de faire mieux que les spécialistes du détecteur inductif. S'ils sont toujours rond et relativement longs, ce n'est certainement pas pour rien !

Par acquis de conscience j'ai regardé ce qui se fait de mieux en capteur inductif industriel, on arrive au mieux à une reproductibilité de mesure de 15µ et une dérive de 2% sur la plage de température de fonctionnement, ce qui représente quand même sur 8mm, 0,16mm ! Tout ca pour 317€ttc
Par contre en mesure optique laser (range 16 à 26mm) on arrive à une reproductibilité de 1µ et une dérive en température de 0,01%, pour un prix TTC de 923€ !!!! :ohgodno:
Des idées d'améliorations https://www.thingiverse.com/Premium/designs
Une question, une précision, un manque de pièces détachées, posez vos questions ici même.
Répondre